<!DOCTYPE html>
<!--[if lt IE 7]> <html class="ie6 no-js" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="ie7 no-js" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="ie8 no-js" lang="en"> <![endif]-->
<!--[if gt IE 8]><!-->
<html class='no-js' lang='en'>
<!--<![endif]-->
<head id='head' itemref='footer' itemscope itemtype='http://schema.org/WebSite'>
<meta charset='utf-8'>
<meta content='IE=edge,chrome=1' http-equiv='X-UA-Compatible'>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"329a531c90","applicationID":"2131593","transactionName":"JlsLRUVYVAoBQhgRBglRBEJSRBcUAUZeBhQ=","queueTime":3,"applicationTime":481,"agentToken":null,"agent":""}</script>
<script type="text/javascript">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</script>
<link href="/feed" rel="alternate" title="Latest Content (Atom)" type="application/atom+xml" />
<link href='/favicon.ico' rel='shortcut icon' type='image/vnd.microsoft.icon'>
<link href='/favicon.ico' rel='icon' type='image/vnd.microsoft.icon'>
<link href='/static_images/apple-touch-icon.png' rel='apple-touch-icon'>
<link href='http://drownedinsound.com/releases/20455/reviews/4152072' rel='canonical'>
<meta content='http://drownedinsound.com/releases/20455/reviews/4152072' property='og:url'>
<meta content='DX7Olwmcv5sOuN2baU+f58V1S65gEef4MrTNK4bSjV0=' name='verify-v1'>
<meta content='all' name='robots'>
<meta content='Album Review: John Grant - Love is Magic' property='og:title'>
<meta content='A writer with his fingers on the pulse of what’s really magic' name='description'>
<meta content='A writer with his fingers on the pulse of what’s really magic' property='og:description'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@drownedinsound' name='twitter:site'>
<meta content='DrownedInSound' property='og:site_name'>
<meta content='190369645092' property='fb:app_id'>
<meta content='article' property='og:type'>
<meta content='http://dis.images.s3.amazonaws.com/105878.jpeg' property='og:image'>
<script type="text/javascript">
//<![CDATA[
var is_ie = true;

//]]>
</script><!--[if !IE]> ><! <![endif]-->
<script type="text/javascript">
//<![CDATA[
var is_ie=false;

//]]>
</script><!-- <![endif] -->
<script src='/javascripts/modernizr.min.js' type='text/javascript'></script>
<script src='/javascripts/respond.min.js' type='text/javascript'></script>
<script src='/javascripts/jquery.min.js' type='text/javascript'></script>
<script>
  //<![CDATA[
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-191154-1']);
  //]]>
</script>
<link href="/assets/mobile-2013f2d379ab11c1a909069b23558d1b.css" media="only screen and  (max-device-width: 740px)" rel="stylesheet" type="text/css" />
<link href="/assets/tablet-26355bf720e9cd179ef966db26439ed3.css" media="only screen and (min-device-width: 740px) and (max-device-width: 1023px)" rel="stylesheet" type="text/css" />
<link href="/assets/application-26a6703cea3ddf7e876c4edec68200d9.css" media="only screen and (min-device-width: 741px)" rel="stylesheet" type="text/css" />
<!--[if IE]>
<link href="/assets/application-26a6703cea3ddf7e876c4edec68200d9.css" media="screen" rel="stylesheet" type="text/css" />
<![endif]-->
<!--[if gte IE 7]>
<link href="/assets/ie7-6209372ea0eef4ef523259d45d1deba6.css" media="screen" rel="stylesheet" type="text/css" />
<![endif]-->
<!-- <![endif] -->
<!--[if lt IE 7]>
<link href="/assets/ie6-1c65a6c7b9015e97850e2f87ee67a30b.css" media="screen" rel="stylesheet" type="text/css" />
<![endif]-->
<!-- <![endif] -->

<!-- TradeDoubler site verification 1546507 -->
<!-- REVENUE SCIENCE AD TAG CODE -->
<script type="text/javascript" >
<!--
var rsi_segs = [];
var segs_beg=document.cookie.indexOf('rsi_segs=');
if(segs_beg>=0){
 segs_beg=document.cookie.indexOf('=',segs_beg)+1;
 if(segs_beg>0){
  var segs_end=document.cookie.indexOf(';',segs_beg);
  if(segs_end==-1)segs_end=document.cookie.length;
  rsi_segs=document.cookie.substring(segs_beg,segs_end).split('|');
}}
var segLen=20
var segQS="",segArr=new Array()
if (rsi_segs.length<segLen){segLen=rsi_segs.length}
for (var i=0;i<segLen;i++){
    segArr=rsi_segs[i].split("_")
    if (segArr.length>1) segQS+=("rsi"+"="+segArr[1]+"+")
}
//-->
</script>
<!-- END REVENUE SCIENCE AD TAG CODE -->
<meta content="authenticity_token" name="csrf-param" />
<meta content="9QXekOPkRJPA+LfayeHx4G6sL8ZC1+KD+XIrCRLwi2c=" name="csrf-token" />
<title>
Album Review: John Grant - Love is Magic / Releases / Releases  //  Drowned In Sound
</title>
<meta content='' name='description'>
<meta content='width=device-width, height=device-height, initial-scale=1, minimum-scale=1' name='viewport'>
<meta content="authenticity_token" name="csrf-param" />
<meta content="9QXekOPkRJPA+LfayeHx4G6sL8ZC1+KD+XIrCRLwi2c=" name="csrf-token" />
<meta content='Drowned In Sound' itemprop='name'>
<meta content='DiS' itemprop='alternateName'>
<meta content='http://www.drownedinsound.com' itemprop='url'>

<script src="/assets/application-01b9217770f4bad9be7fb6a403a25e3b.js" type="text/javascript"></script>

<script>
  //<![CDATA[
    var _gaq=[["_setAccount","UA-191154-1"],["_trackPageview"],["_trackPageLoadTime"]];
    (function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];g.async=1;
    g.src=("https:"==location.protocol?"//ssl":"//www")+".google-analytics.com/ga.js";
    s.parentNode.insertBefore(g,s)}(document,"script"));
  //]]>
</script>

<script>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</script>


<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
            '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type="text/javascript">
  quantSegs=[];
  function qc_results(result) {
    for (var i = 0; i < result.segments.length; i++) {
      quantSegs.push(result.segments[i].id);
    }}
</script>
<script type="text/javascript" src="http://segapi.quantserve.com/api/segments.json?a=p-70RhgKmunzjBs&callback=qc_results">
</script>


<script type='text/javascript'>

  
  window.w00tGPTAdSlots = new Array();
	var tablet_ros_1
  
  
  function refreshAds() {
 	   googletag.cmd.push(function() {
 	 googletag.pubads().refresh()
 	   });
  }
  
 window.onorientationchange = refreshAds;
 

  googletag.cmd.push(function() {

	
	
    var slot1 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_1x1_Footer', [1, 1], 'div-gpt-ad-1403741651790-0').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot2 = googletag.defineOutOfPageSlot('/4183072/DrownedInSound_RecordsArticles_1x1_Footer', 'div-gpt-ad-1403741651790-0-oop').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot3 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_1x1_InPage', [1, 1], 'div-gpt-ad-1403741696566-0').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot4 = googletag.defineOutOfPageSlot('/4183072/DrownedInSound_RecordsArticles_1x1_InPage', 'div-gpt-ad-1403741696566-0-oop').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot5 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_1x1_Skin', [1, 1], 'div-gpt-ad-1403741734660-0').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot6 = googletag.defineOutOfPageSlot('/4183072/DrownedInSound_RecordsArticles_1x1_Skin', 'div-gpt-ad-1403741734660-0-oop').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot7 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_ATF_300x250_300x600', [[300, 250], [300, 600]], 'div-gpt-ad-1403740800621-27').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot8 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_ATF_728x90_970x250', [[728, 90], [952, 250], [970, 90], [970, 125], [970, 250]], 'div-gpt-ad-1403740800621-28').addService(googletag.pubads());

    var slot9 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_BTF_300x250', [300, 250], 'div-gpt-ad-1403740800621-29').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot10 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_BTF_728x90', [728, 90], 'div-gpt-ad-1403740800621-30').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot11 = googletag.defineSlot('/4183072/DrownedInSound_Records_Mobile_300x250_300x600', [[300, 250], [300, 600]], 'div-gpt-ad-1403740800621-31').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    var slot12 = googletag.defineSlot('/4183072/DrownedInSound_RecordsArticles_Mobile_320x50', [320, 50], 'div-gpt-ad-1403740800621-32').addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

    window.w00tGPTAdSlots.push(slot1, slot2, slot3, slot4, slot5, slot6, slot7, slot8, slot9, slot10, slot11, slot12);

	
	
	
	

  
	var mapping1 = googletag.sizeMapping().
	  addSize([0, 0], [728,90]).
	  addSize([970, 0], [970,250]).
	  addSize([1050, 200], []). // Desktop
	  build();
	  
	var mapping2 = googletag.sizeMapping().
	  addSize([0, 0], [300,250]).
	  addSize([1050, 200], []). // Desktop
	  build();
	  
	
	// Tablet ROS code for new campaign
      window.tablet_ros1 = googletag.defineSlot('/4183072/DrownedInSound_Tablet_ROS_970x250', [[728, 90], [970, 250]], 'div-gpt-ad-1435588291664-0').defineSizeMapping(mapping1).addService(googletag.pubads()) //.setTargeting("qcsegs",quantSegs);

      var tablet_ros2 = googletag.defineSlot('/4183072/DrownedInSound_Tablet_ROS_300x250', [[300, 600], [300, 250]], 'div-gpt-ad-1435588291664-1').defineSizeMapping(mapping2).addService(googletag.pubads()).setTargeting("qcsegs",quantSegs);

      window.w00tGPTAdSlots.push(window.tablet_ros1, tablet_ros2);
	  
	
  googletag.pubads().setCentering(true);
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
  googletag.enableServices();

})
  </script>
</head>
<body class='releases bp'>
<div id='fb-root'></div>
<script>
  //<![CDATA[
    (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1&appId=190369645092";
    fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));
  //]]>
</script>





  <!-- records_oop_ -->
  <div id='div-gpt-ad-1403741734660-0-oop' >
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741734660-0-oop'); });
    </script>
  </div>
  <!-- records_oop_ -->
  <div id='div-gpt-ad-1403741696566-0-oop' >
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741696566-0-oop'); });
    </script>
  </div>
  <!-- records_oop_ -->
  <div id='div-gpt-ad-1403741651790-0-oop' >
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741651790-0-oop'); });
    </script>
  </div>



  <!-- records_skin_1x1 -->
  <div id='div-gpt-ad-1403741734660-0'  style="width:1px; height:1px; ">
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741734660-0'); });
    </script>
  </div>
  <!-- records_skin_1x1 -->
  <div id='div-gpt-ad-1403741696566-0'  style="width:1px; height:1px; ">
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741696566-0'); });
    </script>
  </div>

















  <!-- records_atf_728x90_970x250_728x90_970x250 -->
  <div id='div-gpt-ad-1403740800621-28' >
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403740800621-28'); });
    </script>
  </div>







<div id='container'>
<section id='head'>
<div class='head' id='main' role='main'>
<section class='logo' id='logo' itemprop='publisher copyrightholder' itemscope itemtype='http://schema.org/Organization'>
<meta content='Drowned in Sound' itemprop='name'>
<a href="/" itemprop="url"><img alt="Logo" class="logo" itemprop="logo" src="/static_images/logo.png" />
</a></section>
<a href='http://drownedinsound.com/news/4150110-save-drowned-in-sound' id='save-dis'>
<strong>DiS Needs You:</strong>
Save our site »
</a>
</div>
</section>
<section id='ticker'>
<ul class='js-hidden' id='js-news'>
<li class='news_item'><a href="/releases/20455/reviews/4152072?ticker"><b>John Grant</b> - <i>Love is Magic</i> <span title='2' class='timestamp additional'>2&nbsp;minutes&nbsp;ago</span></a></li>
<li class='news_item'><a href="/releases/20457/reviews/4152071?ticker"><b>alt-J</b> - <i>Reduxer</i> <span title='19' class='timestamp additional'>19&nbsp;minutes&nbsp;ago</span></a></li>
<li class='news_item'><a href="/in_depth/4152065-everything-i-do-seems-to-lose-money---dis-meets-spiritualized?ticker"><i>"Everything I do seems to lose money"</i>: DiS Meets <strong>Spiritualized</strong> <span title='0' class='timestamp additional'>about&nbsp;21&nbsp;hours&nbsp;ago</span></a></li>
<li class='news_item'><a href="/in_depth/4152070-broadway-poetry-and-conceptual-recordings--dis-meets-saul-williams?ticker">Broadway, Poetry, and Conceptual Recordings: DiS Meets <strong>Saul Williams</strong> <span title='0' class='timestamp additional'>about&nbsp;21&nbsp;hours&nbsp;ago</span></a></li>
<li class='news_item'><a href="/releases/20454/reviews/4152069?ticker"><b>Kristin Hersh</b> - <i>Possible Dust Clouds</i> <span title='1' class='timestamp additional'>1&nbsp;day&nbsp;ago</span></a></li>
<li class='news_item'><a href="/in_depth/4152067-poise-patience-and-payoff--dis-meets-pip-blom?ticker">Poise, Patience and Payoff: DiS Meets <strong>Pip Blom</strong> <span title='2' class='timestamp additional'>2&nbsp;days&nbsp;ago</span></a></li>
<li class='news_item'><a href="/releases/20453/reviews/4152064?ticker"><b>Marissa Nadler</b> - <i>For My Crimes</i> <span title='5' class='timestamp additional'>5&nbsp;days&nbsp;ago</span></a></li>
<li class='news_item'><a href="/in_depth/4152063-the-era-of-inevitability--dis-meets-mutual-benefit?ticker">The Era Of Inevitability: DiS Meets <strong>Mutual Benefit</strong> <span title='5' class='timestamp additional'>5&nbsp;days&nbsp;ago</span></a></li>
</ul>

</section>
<header id='header'>
<div class='container'>
<nav class='mobile-hide' id='left'>
<ul>
<li class='home-button'><a href="/"><img alt="Logo_home2" src="/images/logo_home2.png" /></a></li>
<li><a href="/records">Records</a></li>
<li><a href="/in_depth">In Depth</a></li>
<li><a href="/in_photos">In Photos</a></li>
<li><a href="/news">Blog</a></li>
<li><a href="http://dispodcast.tumblr.com">Podcast</a></li>
</ul>
</nav>
<nav class='mobile-hide' id='right'>
<ul>
<li id='search_form'>
<div id='cse-search-form'>
<form accept-charset="UTF-8" action="/search" method="get"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>
<label for="s">Search for:</label>
<input id="s" name="s" type="text" />
<input id='search_button' type='submit' value=''>
</form>

</div>
<a href="javascript: void(0)" id="search_nav">Search</a>
</li>
<li><a href="http://community.drownedinsound.com" class="dis11_blue tablet-hide" target="_blank">Community</a></li>
</ul>
</nav>
<div class='header mobile'>
<input id='toggle' type='checkbox'>
<div class='wr'>
<label class='toggle' data-close='Close Menu' data-open='Show Menu' for='toggle' onclick></label>
<ul class='menu'>
<li><a href="/records" class="bt-icon icon-zoom">Records</a></li>
<li><a href="/in_depth" class="bt-icon icon-zoom">In Depth</a></li>
<li><a href="/news" class="bt-icon icon-zoom">Blog</a></li>
<li><a href="http://community.drownedinsound.com" class="bt-icon icon-zoom" target="_blank">Community</a></li>
</ul>
</div>
</div>
</div>

</header>
<section id='content'>
<div id='flash'>
</div>

<div id='page'>
<div id='page-inner'>
<div id='content'>
<section class='content' id='article' itemprop='mainContentOfPage' itemref='logo' itemscope itemtype='http://schema.org/Review'>
<div class='dis11_header' id='caption' itemprop='itemReviewed' itemscope itemtype='http://schema.org/MusicAlbum'>
<h1 itemprop='byArtist' itemscope itemtype='http://schema.org/MusicGroup'>
<a href="/artists/John_Grant" itemprop="url"><span itemprop='name'>John Grant</span>
</a></h1>
<div itemprop='albumRelease' itemscope itemtype='http://schema.org/MusicRelease'>
<h1 class='sub2'>
<a href="/releases/20455"><span itemprop='name'>Love is Magic</span>
</a></h1>
<div id='label-info'>
<h2>
<span class='dis11_blue'>
Label:
<span itemprop='recordLabel'>Bella Union</span>
</span>
<span class='date'>
Release Date:
<time class='date' datetime='2018-10-12' itemprop='datePublished'>12/10/2018</time>
</span>
</h2>
</div>
</div>
</div>
<div class='main_image_wrapper' id='main_article_image'>
<a href="/releases/20455"><img alt="105878" src="http://dis.resized.images.s3.amazonaws.com/540x540/105878.jpeg" /></a>
</div>
<div class='byline'>
<section>
<div class='credits b_author reviewer vcard'>
<span class='author' itemprop='author' itemscope itemtype='http://schema.org/Person'>
<a href="/users/SoundscapeM" class="author" itemprop="url"><img alt="SoundscapeM" height="30" itemprop="image" src="/static_images/avatar.gif" width="30" />
by
<span itemprop='name'>Lee Adcock</span>
</a></span>
<time class='date' datetime='2018-10-10T08:30:41+01:00' itemprop='datePublished'>
October 10th, 2018
</time>
</div>
</section>
</div>

<article class='editorial'>
<!-- / start CMS article content -->
<meta content='A writer with his fingers on the pulse of what’s really magic' itemprop='description'>
<div itemprop='reviewBody'><p>Let’s say, for a second, that your only impression of master balladeer <strong>John Grant</strong> is the cover of this album. You don’t know that this mountain of a man lives in Iceland, an ocean away from his homeland in the northern states. You don’t know either the Warren Zevon-esque, autumnal snark of his earlier days, nor the sneaky fingers stuffing electropop down the spine of each new record. And you certainly don’t know yet (not a stretch, this time) of the neon wiring fully integrated into this full length feature. All you’ve got is a nearly-naked guy covered in feathers, head in a cage, belting his heart out, with the asinine title <i>Love is Magic</i> stamped in the upper-left hand corner. Given no prior knowledge of the distance Grant has climbed to nail this shot, you’re going to stare at him and ask, ‘OK, is this a joke?’<br></br><iframe width="540" height="315" src="https://www.youtube.com/embed/-qtTidRF2V0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe><br></br></p>

<p>Of course, anyone who only spares Grant a surface glance won’t ever hear the full line from which the album’s name stems: “<i>love is magic / whether you like it or not.</i>” That’s the chorus of the title track, where his tried-and-true songwriter mould perfected in The Czars takes the deep plunge into life after romance, and icy synths that evoke The Police. If you don’t listen carefully, you’ll miss that one of the darkest spots on the whole charade sits before “<i>a dresser drawer which is devoid of clean underwear</i> - it’s a clever game, where Grant both preserves and desiccates that clichéd ‘magic’ at the same time. Such is the triumph of the elder songwriter’s work, perched now on an electric plane of mirror ball strobes and totally Eighties aesthetics: Grant himself has moulted now into a sleek new phoenix, one that can giggle at life’s cruelest gags, even when the jest still stings.</p>

<p>Of course, if you’ve kept up with Grant at all, you’d know that fate has dealt him a miserable hand over the years. But that makes the high points of this album even funnier, really – how great is it, after all, that someone who’s wrestled with being openly gay can now write such a deliciously cheesy disco hit as ‘Preppy Boy’? How funny, too, that the song alludes to a heterosexual denying his fab side: "<i>why you chasing that girl in the whale skirt…you know she’ll never understand</i>”. Ditto for ‘He’s Got His Mother’s Hips’, a Peter Gabriel-esque pop blow-out about a cheeseball Don Juan; in both cases, Grant proves to be the real dream boat with his velvet slick delivery. Well, him, or whoever’s behind those suave walking bass lines.</p>

<p>As we’ve mentioned earlier, even the more classic, melancholy numbers seem shot through with diamond dust. ‘Tempest’ follows ‘Love is Magic’, with an even chillier disposition wrought from the dawn of OMD or the Human League. The protagonist’s desperate bid for company after years of rejection dissolves into a literal round of Tempest, another clever game, but this one an Atari arcade classic from 1981. Meanwhile, ‘The Common Snipe’ also harkens back to Grant’s classic form as he gives running commentary on a catalogue of birds. The kicker, of course, is that the most ordinary one of the bunch strikes him as the most beautiful, and ergo the one that keeps him up at night (not the only time this happens on the record, FYI). Both of those contain potent metaphors for life, I’m sure.</p>

<p>While part of Grant’s genius stems from those complex riddles, the more blunt songs aren’t bad, either. The piano ballad that rounds out the album, ‘Touch And Go’, salutes any queer or gender-fluid fellow coming out in this day and age; it’s fitting that a tiny flute lifts up at the end, as if to herald yet another album/life cycle. Concurrently, ‘Smug Cunt’ is Grant’s prerequisite anti-Trump anthem, conveyed with all the dignity and gravity that this current farce of a presidency oh so lacks. And while Grant doesn’t fire any novel shots at Mr. Tiny Hands, the Van Halen-sized synths certainly guide the blows with a satisfying squelch: “<em>now you’re just a smug cunt / who doesn’t even do his own stunts.</em>”</p>

<p>And yet, what with all these poignant cheers to gay identity (and clear flipped birds at incoming homophobes), the centrepiece and crown jewel of <i>Love Is Magic</i> is a seven-minute, robotic tirade called ‘Diet Gum’. Like the ridiculous cover and ostensibly lame title, you might also think Grant’s trolling you with this one, too. In a geeky teen impression that sounds like a pimply John Murphy, the bloke lays into his lover with a series of dorky insults: “<i>do you even know what a collective noun is, stupid-zilla?</i>” Grant might just be taking the piss here, but his impish spirit reflects a writer with his fingers on the pulse of what’s really magic in this era: an understanding of humanity and all its feathery mess.</p>

<div class='hide-me'>![105878](http://dis.resized.images.s3.amazonaws.com/540x310/105878.jpeg)</div>
</div>
<!-- / end CMS article content -->
<section class='score_card' itemprop='reviewRating' itemscope itemtype='http://schema.org/Rating'>
<meta content='0' itemprop='worstRating'>
<meta content='10' itemprop='bestRating'>
<ul>
<li>
<div class='dis11_score' id='dis' itemprop='ratingValue'>
9
</div>
<div class='source'>
Lee Adcock's Score
</div>
</li>
</ul>
</section>
</article>
<a href="/login">Log-in to rate this record out of 10</a>
<div class='social_bookmarks content'>
<div class='share-section'>
<strong>Share on</strong>
<div class='share-buttons'>
<a class='share-button share-facebook' href='#' onclick="FB.ui({ method: 'share_open_graph', action_type: 'og.likes', action_properties: JSON.stringify({object: 'http://drownedinsound.com/releases/20455/reviews/4152072'})}); return false;"> </a>
<a class='share-button share-twitter' href='https://twitter.com/share?related=drownedinsound%3ADrownedInSound&amp;text=John+Grant+-+Love+is+Magic&amp;url=http%3A%2F%2Fdrownedinsound.com%2Freleases%2F20455%2Freviews%2F4152072&amp;via=drownedinsound' target='_blank' title='Share this article on Twitter'> </a>
</div>
</div>
<div class='donate share-section'>
<strong>Love DiS?</strong> <a href="http://drownedinsound.com/news/4148897-become-a-patron-of-dis">Become a Patron of the site here »</a>
</div>
</div>


  <!-- records_btf_728x90_728x90 -->
  <div id='div-gpt-ad-1403740800621-30'  style="width:728px; height:90px; ">
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403740800621-30'); });
    </script>
  </div>


</section>
<section class='sidebar' id='article_sidebar'>

  <!-- records_atf_300x250_300x600_300x250_300x600 -->
  <div id='div-gpt-ad-1403740800621-27' >
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403740800621-27'); });
    </script>
  </div>


<hr class='hr3 hr1'>
<hr class='hr2'>
<section id='sidebar_latest'>
<h2><a href="/lists/latest">LATEST</a></h2>
<ul id='column'>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/releases/20455/reviews/4152072'>
<p class='main'>John Grant</p>
<p class='sub'>Love is Magic</p>
</a>

</li>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/releases/20457/reviews/4152071'>
<p class='main'>alt-J</p>
<p class='sub'>Reduxer</p>
</a>

</li>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/in_depth/4152065-everything-i-do-seems-to-lose-money---dis-meets-spiritualized'>
<p class='main'>&quot;Everything I do seems to lose money&quot;: DiS Meets Spiritualized</p>
</a>

</li>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/in_depth/4152070-broadway-poetry-and-conceptual-recordings--dis-meets-saul-williams'>
<p class='main'>Broadway, Poetry, and Conceptual Recordings: DiS Meets Saul Williams</p>
</a>

</li>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/releases/20454/reviews/4152069'>
<p class='main'>Kristin Hersh</p>
<p class='sub'>Possible Dust Clouds</p>
</a>

</li>
<li class='sidebar_latest'>
<hr class='title'>
<a href='/in_depth/4152067-poise-patience-and-payoff--dis-meets-pip-blom'>
<p class='main'>Poise, Patience and Payoff: DiS Meets Pip Blom</p>
</a>

</li>

</ul>
</section>


  <!-- records_btf_300x250_300x250 -->
  <div id='div-gpt-ad-1403740800621-29'  style="width:300px; height:250px; ">
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403740800621-29'); });
    </script>
  </div>


</section>
<hr class='hr4 hr1'>
<hr class='hr2'>
<div class="nav-release">
    <div class="nav-left">
      <a href="/releases/20457/reviews/4152071">
          <div class="nav-info">
            <div class="nav-pointer"><img alt="Left-arrow" src="/images/left-arrow.png" /> </div>
            <h1 class="main">alt-J</h1>
            <h1 class="sub2">Reduxer</h1>
            <div class="mobile previous"><img alt="Mobback" src="/images/mobile/mobback.png" /></div>
          </div>
          <div class="nav-pack"><img alt="105877" height="100" src="http://dis.images.s3.amazonaws.com/105877.jpeg" width="100" /></div>
      </a>
</a>    </div>

</div>
<hr class='hr4 hr1'>
<hr class='hr2'>
<section class='overview' id='latest-foot'>
<h2><a href="/lists/latest">LATEST</a></h2>
<ul id='column1'>
<h3 class='section'>
<span class='section_title'>
review
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/releases/20455/reviews/4152072">John Grant - Love is Magic</a>
</p>
</div>
</hr>
<li class=''>
<a href='/releases/20455/reviews/4152072'>
<img alt="105878" src="http://dis.resized.images.s3.amazonaws.com/220x124/105878.jpeg" title="John Grant - Love is Magic" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
review
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/releases/20457/reviews/4152071">alt-J - Reduxer</a>
</p>
</div>
</hr>
<li class=''>
<a href='/releases/20457/reviews/4152071'>
<img alt="105877" src="http://dis.resized.images.s3.amazonaws.com/220x124/105877.jpeg" title="alt-J - Reduxer" />
</a>
</li>

</ul>
<ul id='column2'>
<h3 class='section'>
<span class='section_title'>
Interview
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4152065-everything-i-do-seems-to-lose-money---dis-meets-spiritualized">"Everything I do seems to lose money": DiS Meet...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/4152065-everything-i-do-seems-to-lose-money---dis-meets-spiritualized'>
<img alt="105871" src="http://dis.resized.images.s3.amazonaws.com/220x124/105871.jpeg" title="&quot;Everything I do seems to lose money&quot;: DiS Meets Spiritualized" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
Interview
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4152070-broadway-poetry-and-conceptual-recordings--dis-meets-saul-williams">Broadway, Poetry, and Conceptual Recordings: Di...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/4152070-broadway-poetry-and-conceptual-recordings--dis-meets-saul-williams'>
<img alt="105876" src="http://dis.resized.images.s3.amazonaws.com/220x124/105876.jpeg" title="Broadway, Poetry, and Conceptual Recordings: DiS Meets Saul Williams" />
</a>
</li>

</ul>
<ul id='column3'>
<h3 class='section'>
<span class='section_title'>
review
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/releases/20454/reviews/4152069">Kristin Hersh - Possible Dust Clouds</a>
</p>
</div>
</hr>
<li class=''>
<a href='/releases/20454/reviews/4152069'>
<img alt="105875" src="http://dis.resized.images.s3.amazonaws.com/220x124/105875.jpeg" title="Kristin Hersh - Possible Dust Clouds" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
Interview
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4152067-poise-patience-and-payoff--dis-meets-pip-blom">Poise, Patience and Payoff: DiS Meets Pip Blom</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/4152067-poise-patience-and-payoff--dis-meets-pip-blom'>
<img alt="105873" src="http://dis.resized.images.s3.amazonaws.com/220x124/105873.jpeg" title="Poise, Patience and Payoff: DiS Meets Pip Blom" />
</a>
</li>

</ul>
<ul id='column4'>
<h3 class='section'>
<span class='section_title'>
review
</span>
</h3>
<hr class='greatest last'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/releases/20453/reviews/4152064">Marissa Nadler - For My Crimes</a>
</p>
</div>
</hr>
<li class='last'>
<a href='/releases/20453/reviews/4152064'>
<img alt="105870" src="http://dis.resized.images.s3.amazonaws.com/220x124/105870.jpeg" title="Marissa Nadler - For My Crimes" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
Interview
</span>
</h3>
<hr class='greatest last'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4152063-the-era-of-inevitability--dis-meets-mutual-benefit">The Era Of Inevitability: DiS Meets Mutual Benefit</a>
</p>
</div>
</hr>
<li class='last'>
<a href='/in_depth/4152063-the-era-of-inevitability--dis-meets-mutual-benefit'>
<img alt="105869" src="http://dis.resized.images.s3.amazonaws.com/220x124/105869.jpeg" title="The Era Of Inevitability: DiS Meets Mutual Benefit" />
</a>
</li>

</ul>
<a href="/lists/latest" class="show" id="show_more">MORE</a>
</section>

<hr class='hr4 hr1'>
<hr class='hr2'>
<section class='overview' id='greatest_hits'>
<h2><a href="/lists/greatest-hits">GREATEST HITS</a></h2>
<ul id='column1'>
<h3 class='section'>
<span class='section_title'>
feature
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/2485286-radioheads-in-rainbows--the-fans-verdict">Radiohead's In Rainbows: the fans' verdict</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/2485286-radioheads-in-rainbows--the-fans-verdict'>
<img alt="27997" src="http://dis.resized.images.s3.amazonaws.com/220x124/27997.gif" title="Radiohead&#x27;s In Rainbows: the fans&#x27; verdict" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
news
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/news/4150715-our-independent-music-filled-alternative-to-new-music-friday">Our Independent music filled alternative to New...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/news/4150715-our-independent-music-filled-alternative-to-new-music-friday'>
<img alt="104374" src="http://dis.resized.images.s3.amazonaws.com/220x124/104374.jpeg" title="Our Independent music filled alternative to New Music Friday" />
</a>
</li>

</ul>
<ul id='column2'>
<h3 class='section'>
<span class='section_title'>
feature
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/2684085-the-national--we-nearly-lost-our-minds-making-boxer">The National: "We nearly lost our minds making ...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/2684085-the-national--we-nearly-lost-our-minds-making-boxer'>
<img alt="30199" src="http://dis.resized.images.s3.amazonaws.com/220x124/30199.jpeg" title="The National: &quot;We nearly lost our minds making Boxer&quot;" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
Interview
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4147988-dis-meets-anton-newcombe-from-the-brian-jonestown-massacre">DiS meets Anton Newcombe from The Brian Jonesto...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/in_depth/4147988-dis-meets-anton-newcombe-from-the-brian-jonestown-massacre'>
<img alt="96546" src="http://dis.resized.images.s3.amazonaws.com/220x124/96546.jpeg" title="DiS meets Anton Newcombe from The Brian Jonestown Massacre" />
</a>
</li>

</ul>
<ul id='column3'>
<h3 class='section'>
<span class='section_title'>
review
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/releases/7014/reviews/587676-arctic-monkeys-whatever-people-say-i-am-thats-what-i-m-not">Arctic Monkeys - Whatever People Say I Am, That...</a>
</p>
</div>
</hr>
<li class=''>
<a href='/releases/7014/reviews/587676-arctic-monkeys-whatever-people-say-i-am-thats-what-i-m-not'>
<img alt="12425" src="http://dis.resized.images.s3.amazonaws.com/220x124/12425.jpeg" title="Arctic Monkeys - Whatever People Say I Am, That&#x27;s What I&#x27;m Not" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
news
</span>
</h3>
<hr class='greatest'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/news/1591719-brian-may-in-dis-hating-shocker">Brian May in DiS-hating shocker!</a>
</p>
</div>
</hr>
<li class=''>
<a href='/news/1591719-brian-may-in-dis-hating-shocker'>
<img alt="20986" src="http://dis.resized.images.s3.amazonaws.com/220x124/20986.jpeg" title="Brian May in DiS-hating shocker!" />
</a>
</li>

</ul>
<ul id='column4'>
<h3 class='section'>
<span class='section_title'>
Staff-generated
</span>
</h3>
<hr class='greatest last'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/4137961-year-2000-a-playlist-of-songs-wot-soundtracked-the-launch-of-dis">Year 2000 - A Playlist of Songs Wot Soundtracke...</a>
</p>
</div>
</hr>
<li class='last'>
<a href='/in_depth/4137961-year-2000-a-playlist-of-songs-wot-soundtracked-the-launch-of-dis'>
<img alt="53565" src="http://dis.resized.images.s3.amazonaws.com/220x124/53565.jpeg" title="Year 2000 - A Playlist of Songs Wot Soundtracked the Launch of DiS" />
</a>
</li>
<h3 class='section'>
<span class='section_title'>
feature
</span>
</h3>
<hr class='greatest last'>
<div class='greatest-text'>
<p class='tooltip_trigger'>
<a href="/in_depth/762230-this-is-our-music--sxsw-06-with-no-prospects">This is Our Music: SXSW '06 With No Prospects</a>
</p>
</div>
</hr>
<li class='last'>
<a href='/in_depth/762230-this-is-our-music--sxsw-06-with-no-prospects'>
<img alt="94784" src="http://dis.resized.images.s3.amazonaws.com/220x124/94784.jpeg" title="This is Our Music: SXSW &#x27;06 With No Prospects" />
</a>
</li>

</ul>
<a href="/lists/greatest-hits" class="show" id="show_more">MORE</a>
</section>


</div>
<div id='sidebar'>

</div>
<br class='clear'>
</div>
</div>

</section>
<footer id='footer'>
<div class='footer' id='footer'>
<div class='container'>
<img alt="Drowned in Sound" class="logo2" src="/static_images/logo2.jpg" />
<ul class='footer-list'>
<li class='first-li'>DROWNED IN SOUND</li>
<li><a href="/">HOME</a></li>
<li><a href="/news/4147106-dis-site-map-columns-takeovers-albums-of-the-year-and-more">SITE MAP</a></li>
<li><a href="/news">NEWS</a></li>
<li><a href="/in_depth">IN DEPTH</a></li>
<li><a href="/in_photos">IN PHOTOS</a></li>
<li><a href="/records">RECORDS</a></li>
<li><a href="/lists/recommended-records">RECOMMENDED RECORDS</a></li>
<li><a href="/lists/albums-of-the-year">ALBUMS OF THE YEAR</a></li>
<li><a href="/lists/festivals">FESTIVAL COVERAGE</a></li>
<li><a href="http://community.drownedinsound.com" target="_blank">COMMUNITY</a></li>
<li><a href="http://community.drownedinsound.com/c/music" target="_blank">MUSIC FORUM</a></li>
<li><a href="http://community.drownedinsound.com/c/social" target="_blank">SOCIAL BOARD</a></li>
<li><a href="http://community.drownedinsound.com/c/site-feedback" target="_blank">REPORT ERRORS</a></li>
</ul>
<ul class='footer-list'>
<li class='contact'><a href="/contact">CONTACT US</a></li>
<li><a href="http://eepurl.com/fBubk">JOIN OUR MAILING LIST</a></li>
<li class='first-li mid'>FOLLOW DiS</li>
<li><a href="https://plus.google.com/+DrownedinSound" itemprop="sameAs" rel="publisher">GOOGLE+</a></li>
<li><a href="http://facebook.com/drownedinsound" itemprop="sameAs">FACEBOOK</a></li>
<li><a href="http://twitter.com/drownedinsound" itemprop="sameAs">TWITTER</a></li>
<li><a href="http://shuffler.fm/sites/drowned-in-sound" itemprop="sameAs">SHUFFLER</a></li>
<li><a href="http://drownedinsoundcloud.com" itemprop="sameAs">TUMBLR</a></li>
<li><a href="http://youtube.com/drownedinsound" itemprop="sameAs">YOUTUBE</a></li>
<li><a href="/feed">RSS FEED</a></li>
<li><a href="http://feedburner.google.com/fb/a/mailverify?uri=DrownedInSound&amp;amp;loc=en_US">RSS EMAIL SUBSCRIBE</a></li>
</ul>
<ul class='footer-list'>
<li class='first-li'>MISC</li>
<li><a href="http://drownedinsound.com/terms">TERM OF USE</a></li>
<li><a href="http://drownedinsound.com/privacy">PRIVACY</a></li>
<li><a href="http://w00tmedia.net">ADVERTISING</a></li>
<li><a href="http://en.wikipedia.org/wiki/Drowned_in_sound" itemprop="sameAs">OUR WIKIPEDIA</a></li>
</ul>
<h5 class='copyrights'>
&copy;
 2000-2018 DROWNED IN SOUND
</h5>
</div>
</div>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PRGQCZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PRGQCZ');</script>
<!-- End Google Tag Manager -->

<script type="text/JavaScript">
  cont = jQuery('.container')[0].innerHTML
  if (cont.indexOf("Video Wall") >= 0){
    jQuery('head').append('<link rel="stylesheet" href="/xtakeover.css" type="text/css" />');
  }
</script>


  <!-- records_footer_1x1 -->
  <div id='div-gpt-ad-1403741651790-0'  style="width:1px; height:1px; ">
    <script type='text/javascript'>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1403741651790-0'); });
    </script>
  </div>







</footer>
</div>
</body>
<script src='/javascripts/cycle-plugin.js' type='text/javascript'></script>
</html>

